package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a [^>]*?(title="[^"]*")`)
var str = `<a title="my lovely dog" >`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}