import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?<protocol>\\w*?):\\/\\/(?<authority>(?<mnemonic>\\w*).(?<host>(?<clientid>(?<client>\\w*)-?(?<environment>\\w*)).(?<domain>[\\w-.]*))(?::?(?<port>\\d*)))\\/(?<path>[\\w-]*)\\s*$)";
final String string = "https://pii.ngkf-qa.commloanservices.com:5999/qa2 \n"
+ "https://pii.ngkf-qa.pncint.net/qa1 \n"
+ "https://pii.ngkf-qa.pncint.net/qa2 \n"
+ "https://pii.rait.commloanservices.com/PII \n"
+ "https://pii.rait.pncint.net/PII \n"
+ "https://pii.rait-qa.commloanservices.com/qa1 \n"
+ "https://pii.rait-qa.pncint.net/qa1 \n"
+ "https://pii.situs.commloanservices.com/PII \n"
+ "https://pii.situs.pncint.net/PII \n"
+ "https://pii.situs-qa.commloanservices.com/qa1 \n"
+ "https://pii.situs-qa.commloanservices.com/qa2 \n"
+ "https://pii.situs-qa.pncint.net/qa1 \n"
+ "https://pii.situs-qa.pncint.net/qa2 \n"
+ "https://pii.situs-rnd.pncint.net/dev1 \n"
+ "https://pii.situs-rnd.pncint.net/dev2 \n"
+ "https://pii.situs-uat.pncint.net/test1 \n"
+ "https://pii.situs-uat.pncint.net/test2 \n"
+ "https://pii.suntrust.commloanservices.com/PII \n"
+ "https://pii.suntrust.pncint.net/pii \n"
+ "https://pii.suntrust-qa.commloanservices.com/qa1 \n"
+ "https://pii.suntrust-qa.commloanservices.com/qa2 \n"
+ "https://pii.suntrust-qa.pncint.net/qa1 \n"
+ "https://pii.suntrust-qa.pncint.net/qa2 \n"
+ "https://pii.wd.commloanservices.com/PII \n"
+ "https://pii.wd.pncint.net/pii \n"
+ "https://pii.wd-qa.commloanservices.com/qa1 \n"
+ "https://pii.wd-qa.commloanservices.com/qa2 \n"
+ "https://pii.wd-qa.pncint.net/qa1 \n"
+ "https://pii.wd-qa.pncint.net/qa2 \n"
+ "https://rdt.midlandls.pncint.net/pnclms \n"
+ "https://rdt.midlandls-qa.pncint.net/pnclms \n"
+ "https://tci-pnc.pncint.net/ \n"
+ "https://tci-pnc-qa-pncint.net/ \n"
+ "https://tci-pnc-rnd.pncint.net/ \n"
+ "https://tci-pnc-uat.pncint.net/ \n"
+ "https://wlm.midlandls.pncint.net/ \n"
+ "https://wlm.midlandls-qa.pncint.net/qa1 \n"
+ "https://wlm.midlandls-qa.pncint.net/qa2 \n"
+ "https://wlm-app.midlandls-qa.pncint.net/qa1-fdic \n"
+ "https://wlm-app.midlandls-qa.pncint.net/qa2fdic ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}