#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):\s"(?:.*)\s([a-zA-Z]+(?:['-][a-zA-Z]+)*)\s(?=[A-Z]{2,3})(?:.*)""
Local $sString = "[" & @CRLF & _
"{"name": "Hon Tony Abbott MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Anthony Albanese MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr John Alexander OAM, MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Dr Anne Aly MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Karen Andrews MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Kevin Andrews MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Adam Bandt MP", "party": "Australian Greens"}," & @CRLF & _
"{"name": "Ms Julia Banks MP", "party": "Independent"}," & @CRLF & _
"{"name": "Hon Sharon Bird MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Chris Bowen MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Russell Broadbent MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Scott Buchholz MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Tony Burke MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Linda Burney MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Mark Butler MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Terri Butler MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Anthony Byrne MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Dr Jim Chalmers MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Nick Champion MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Darren Chester MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Ms Lisa Chesters MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr George Christensen MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Hon Jason Clare MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Sharon Claydon MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon David Coleman MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Julie Collins MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Pat Conroy MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Mark Coulton MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Mr Chris Crewther MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Milton Dick MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Mark Dreyfus QC, MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Damian Drum MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Hon Peter Dutton MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Justine Elliot MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Warren Entsch MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Trevor Evans MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Jason Falinski MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Joel Fitzgibbon MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Paul Fletcher MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Ms Nicolle Flint MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Dr Mike Freelander MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Josh Frydenberg MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Andrew Gee MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Mr Steve Georganas MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Andrew Giles MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Dr David Gillespie MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Mr Ian Goodenough MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Patrick Gorman MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Luke Gosling OAM, MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Ross Hart MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Andrew Hastie MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Alex Hawke MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Chris Hayes MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Sarah Henderson MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Julian Hill MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Kevin Hogan MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Mr Luke Howarth MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Greg Hunt MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Ed Husic MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Steve Irons MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Stephen Jones MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Barnaby Joyce MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Hon Bob Katter MP", "party": "Katter's Australian Party"}," & @CRLF & _
"{"name": "Ms Ged Kearney MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Justine Keay MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Michael Keenan MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Craig Kelly MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Dr Mike Kelly AM, MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Matt Keogh MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Peter Khalil MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Catherine King MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Madeleine King MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Susan Lamb MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Andrew Laming MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Michelle Landry MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Mr Julian Leeser MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Dr Andrew Leigh MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Sussan Ley MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon David Littleproud MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Mrs Nola Marino MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Richard Marles MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Emma McBride MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Michael McCormack MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Hon Dr John McVeigh MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Brian Mitchell MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Rob Mitchell MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Scott Morrison MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Ben Morton MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Shayne Neumann MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Llew O'Brien MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Mr Ted O'Brien MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Brendan O'Connor MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Ken O'Dowd MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Hon Kelly O'Dwyer MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Ms Clare O'Neil MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Cathy O'Toole MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Julie Owens MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Tony Pasin MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Graham Perrett MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Dr Kerryn Phelps AM, MP", "party": "Independent"}," & @CRLF & _
"{"name": "Hon Keith Pitt MP", "party": "The Nationals"}," & @CRLF & _
"{"name": "Hon Tanya Plibersek MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Christian Porter MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Melissa Price MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Christopher Pyne MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Rowan Ramsey MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Amanda Rishworth MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Stuart Robert MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Ms Michelle Rowland MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Joanne Ryan MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Rebekha Sharkie MP", "party": "Centre Alliance"}," & @CRLF & _
"{"name": "Hon Bill Shorten MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Tony Smith MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Warren Snowdon MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Ms Anne Stanley MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Michael Sukkar MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Ms Meryl Swanson MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Angus Taylor MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Dan Tehan MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Ms Susan Templeman MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Matt Thistlethwaite MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Hon Alan Tudge MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Ms Maria Vamvakinou MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Bert van Manen MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Ross Vasta MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Andrew Wallace MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Tim Watts MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mrs Lucy Wicks MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Andrew Wilkie MP", "party": "Independent"}," & @CRLF & _
"{"name": "Mr Josh Wilson MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Rick Wilson MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Tim Wilson MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Jason Wood MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Hon Ken Wyatt AM, MP", "party": "Liberal Party of Australia"}," & @CRLF & _
"{"name": "Mr Tony Zappia MP", "party": "Australian Labor Party"}," & @CRLF & _
"{"name": "Mr Trent Zimmerman MP", "party": "Liberal Party of Australia"}" & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")