# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(https?:\/\/[^\"<\s]+)(?![^<>]*>|[^\"]*?<\/a)"
test_str = ("\"http://www.website.com\"\n"
"https://www.website.com\n"
"\"ftp://www.website.com\n"
"ftps://www.website.com\n\n"
"<u>http://www.website.com</u>\n"
"This is a link http://www.website.com that is not linked ftp://www.website.com\n"
"This is a long link http://www.website.com/index.htm?foo=bar\n\n"
"<a href=\"http://www.website.com\" target=\"_blank\">http://website.com</a >\n"
"<a href=\"https://www.website.com\">http://website.com</a>\n"
"<a href=\"http://www.website.com\"><u>http://www.website.com</u></a>\n"
"<a href=\"ftp://www.website.com\">ftp://www.website.com</a>\n\n\n"
"<img src=\"http://www.website.com\" target=\"_blank\"/>\n\n"
"<a href=\"http://www.website.com\" target=\"_blank\">\n"
"http://website.com\n"
"</a>\n\n\n"
"<a href=\"http://www.website.com\">\n\n\n"
"http://www.website.com\n\n"
"http://www.website.com \n"
" \n"
"</a>\n\n"
"Lorem ipsum Test dolor sit amet, consetetur sadhttp://url.comipscing elitr, sed diam <a href=\"http://Test.com/url\">Test</a> eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam http://url.com et justo...\n\n\n"
"<a href=\"http://www.website.com\">\n\n"
"http://www.website.com\n"
"<img src=\"http://www.website.com\" target=\"_blank\"/>\n"
"http://www.website.com\n"
"</a>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.