import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:ht|f)tps?:\\/\\/[-a-zA-Z0-9.]+\\.[a-zA-Z]{2,3}(\\/[^\"<]*)?";
final String string = "href=\"http://vacante2016.eu/tr/17599/51743713/c4f5eadf38eb475d39e3cde=ca9201538\" \n"
+ "\"http://vacante2016.eu/clk/17599/5=\\r\\n1743713/150132/bf7639dd7e7aa48c9197a52a8c61e168\"><img";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}