import Foundation
let pattern = #"<div class=\"((?:[^>]*?))\">(.*?)<div class=\"((?:[^>]*?))\">((?:(?!<div ).)*?)<\/div><div class=\"((?:[^>]*?))\" title=\"((?:[^>]*?))\" style=\"((?:[^>]*?))\"><div class=\"clear\"><\/div>((?:(?!<div ).)*?)<div class=\"clear\"><\/div><div class=\"(?:(?:[^>]*?))\">((?:(?!<div ).)*?)<\/div><\/div><\/div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = ##"""
<div class="hide spoiler-wrap"> <div class="hide spoiler-body" title="MediaInfo:">Общее<br />Полное Ð¸Ð¼Ñ : Svalka.2014.D.HDRip.1400MB.nnm-club.avi<br />Формат : AVI<br />Формат/Ð˜Ð½Ñ„Ð¾Ñ€Ð¼Ð°Ñ†Ð¸Ñ : Audio Video Interleave<br />Размер файла : 1,37 Гбайт<br />ПродолжительноÑть : 1 ч. 53 м.<br />Общий поток : 1722 Кбит/Ñек<br />Программа ÐºÐ¾Ð´Ð¸Ñ€Ð¾Ð²Ð°Ð½Ð¸Ñ : VirtualDubMod 1.5.10.2 (build 2540/release)<br />Библиотека ÐºÐ¾Ð´Ð¸Ñ€Ð¾Ð²Ð°Ð½Ð¸Ñ : VirtualDubMod build 2540/release<br /><br />Видео<br />Идентификатор : 0<br />Формат : MPEG-4 Visual<br />Профиль формата : Advanced Simple@L5<br />Параметр BVOP формата : 2<br />Параметр QPel формата : Ðет<br />Параметр GMC формата : Без точки перехода<br />Параметр матрицы формата : Default (MPEG)<br />Идентификатор кодека : XVID<br />Идентификатор кодека/ПодÑказка : XviD<br />ПродолжительноÑть : 1 ч. 53 м.<br />Битрейт : 1265 Кбит/Ñек<br />Ширина : 720 пикÑелей<br />Ð’Ñ‹Ñота : 304 пикÑелÑ<br />Соотношение Ñторон : 2,35:1<br />ЧаÑтота кадров : 23,976 кадра/Ñек<br />Цветовое проÑтранÑтво : YUV<br />СубдиÑÐºÑ€ÐµÑ‚Ð¸Ð·Ð°Ñ†Ð¸Ñ Ð½Ð°ÑыщенноÑти : 4:2:0<br />Ð‘Ð¸Ñ‚Ð¾Ð²Ð°Ñ Ð³Ð»ÑƒÐ±Ð¸Ð½Ð° : 8 бит<br />Тип развёртки : ПрогреÑÑивнаÑ<br />Метод ÑÐ¶Ð°Ñ‚Ð¸Ñ : С потерÑми<br />Бит/(ПикÑели*Кадры) : 0.241<br />Размер потока : 1,00 Гбайт (73%)<br />Библиотека ÐºÐ¾Ð´Ð¸Ñ€Ð¾Ð²Ð°Ð½Ð¸Ñ : XviD 1.2.1 (UTC 2008-12-04)<br /><br />Ðудио<br />Идентификатор : 1<br />Формат : AC-3<br />Формат/Ð˜Ð½Ñ„Ð¾Ñ€Ð¼Ð°Ñ†Ð¸Ñ : Audio Coding 3<br />РаÑширение режима : CM (complete main)<br />Параметр Endianness формата : Big<br />Идентификатор кодека : 2000<br />ПродолжительноÑть : 1 ч. 53 м.<br />Вид битрейта : ПоÑтоÑнный<br />Битрейт : 448 Кбит/Ñек<br />Каналы : 6 каналов<br />РаÑположение каналов : Front: L C R, Side: L R, LFE<br />ЧаÑтота : 48,0 КГц<br />Ð‘Ð¸Ñ‚Ð¾Ð²Ð°Ñ Ð³Ð»ÑƒÐ±Ð¸Ð½Ð° : 16 бит<br />Метод ÑÐ¶Ð°Ñ‚Ð¸Ñ : С потерÑми<br />Размер потока : 364 Мбайт (26%)<br />Выравнивание : Разделение по промежуткам<br />ПродолжительноÑть промежутка : 42 мÑ. (1,00 видеокадр)<br />Ð’Ñ€ÐµÐ¼Ñ Ð¿Ñ€ÐµÐ´Ð·Ð°Ð³Ñ€ÑƒÐ·ÐºÐ¸ промежутка : 500 мÑ. </div></div> <span style="text-align: center; display: block;"><span style="font-family: Georgia"><span style="font-style: italic"><span style="font-weight: bold">Скриншоты:</span></span></span><br /><a href="http://i.imgur.com/QWBp1XX.jpg" class="highslide" onclick="return hs.expand(this,{slideshowGroup: 'true'})" rel="nofollow"><var class="postImg" title="http://i.imgur.com/x5fwIsl.jpg"> </var></a> <a href="http://i.imgur.com/epCr2vm.jpg" class="highslide" onclick="return hs.expand(this,{slideshowGroup: 'true'})" rel="nofollow"><var class="postImg" title="http://i.imgur.com/PxuhNxw.jpg"> </var></a> <a href="http://i.imgur.com/m1CVJDO.jpg" class="highslide" onclick="return hs.expand(this,{slideshowGroup: 'true'})" rel="nofollow"><var class="postImg" title="http://i.imgur.com/yq1rw0d.jpg"> </var></a> <a href="http://i.imgur.com/1bnvM2E.jpg" class="highslide" onclick="return hs.expand(this,{slideshowGroup: 'true'})" rel="nofollow"><var class="postImg" title="http://i.imgur.com/CtETZAv.jpg"> </var></a> </span><br /><br /><span style="font-weight: bold">Ð’Ñ€ÐµÐ¼Ñ Ñ€Ð°Ð·Ð´Ð°Ñ‡Ð¸:</span> 24/7 (до 10 Ñкачавших)</span></td>
</tr>
<tr><td colspan="2">
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}