$re = '/(.+)@amu.edu.pl \1/m';
$str = 'jassem@amu.edu.pl jassem';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);