re = /^[A-Za-z]+(?:\s+[A-Za-z]+)*(?=:)/m
str = 'Necessity:(noun)the need for something, or something that is needed Example: In my work, a computer is a necessity.
Lay of the land: (idiom n. Or v.)the general state or condition of affairs under consideration; the facts of a situation Example: We asked a few questions to get the lay of the land
Mumble:(verb) to speak quietly or in an unclear way so that the words are difficult to understand Example: She mumbled something about needing to be home, then left.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end