re = /(?<![{a-zA-Z0-9_])[a-zA-Z_][a-zA-Z0-9_]*|[a-zA-Z_][a-zA-Z0-9_]*(?![}a-zA-Z0-9_])/
str = '{_sa2lary_} + {3+2} * 9 * 2 + 16464131630 + _sal4ary} + {salar7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end