re = /^\$?([0-9]{1,3},([0-9]{3},)*[0-9]{3}|[0-9]+)(.[0-9][0-9])?$/
str = '123,020.00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end