$re = '/\s(?![^)]*\()/';
$str = 'Classic-T50 (Black Grey)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);