package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b@\S+`)
var str = `h@i`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}