package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\B@\S+`)
var str = `h@i
hi @hello @me`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}