$re = '/^((?!self).)+\._(\w+?)$/m';
$str = 'object._attr
a._aaa
self._attr
object._';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);