re = /#(\w+)/m
str = '#user$,#you #fun #go #userfun024 #assassinscreed2020valhala'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end