re = /.*?(t)(s)(t)|.*?(t)(s).*?(t)|.*?(t).*?(s)(t)|(t).*?(s).*?(t)/
str = 'this is a test testst string'
# Print the match result
str.match(re) do |match|
puts match.to_s
end