const regex = /f=<([\w\-.]+@[\w\-.]+)> t=<([\w\-.]+@[\w\-.]+)>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('f=<([\\w\\-.]+@[\\w\\-.]+)> t=<([\\w\\-.]+@[\\w\\-.]+)>', '')
const str = `f=<remolabarca0@abcde.com> t=<remo_labarca1@hotmail.virgilio.com> t=<vacca.carlo@live.org>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}