$re = '/^(\+)([0-9]-[0-9]{3}-[0-9]{3}-[0-9]{4})/';
$str = '+1-646-222-3333';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);