package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ae]`)
var str = `gray grey`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}