$re = '/(?<=from..)(?!@)([\/.]*)(\/module\/)/';
$str = 'import { service1 } from "./module/1.service";
import { service2 } from "../module/2.service";
import { service3 } from "../../module/3.service";
import { service4 } from "../../../module/4.service";
import { service5 } from "../../../../module/5.service";
import { service6 } from "../../../../../module/6.service";
import { service7 } from "../../../../../../module/7.service";
import { service8 } from "../../../../../../../module/8.service";
import { service9 } from ".23455./module/9.service";
import { service10 } from "dontinclude/../module/10.service";
import { service11 } from "../dontinclude/../module/11.service";
import { service12 } from "@module/12.service";
import { service13 } from "@module/13.service";
import { service11 } from "@module/14.service";';
$subst = "@module";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;