$re = '/^\"[^\\\\]+\\\\\\\\Rem\\\\\\\\[^\\\\]+\"$/m';
$str = '"Cliente1\\\\Rem\\\\COB0111111.REM.txt"
"Cliente1\\\\Rem\\\\23123123.REM.txt"
"Cliente1\\\\OK\\\\COB02222222.REM.txt"
"Cliente1\\\\Ret\\\\COB0613062019.REM.txt"
"COB0613062019.REM.txt"
"Cliente2\\\\COB0613062019.REM.txt"
"Cliente2\\\\Rem\\\\COB0633333.REM.txt"
"Cliente2\\\\Rem\\\\pasta2\\\\COB02123123.REM.txt"
"Cliente2\\\\Bla\\\\Rem\\\\COB0613062019.REM.txt"
"Cliente1\\\\COB0613062019.REM.txt"
"Rem\\\\COB0613062019.REM.txt"
"Rem"
"Cliente3"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);