#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^function (\w+)\("
Local $sString = "function Date(Y, M, D, h, m, s, ms) { // 1397" & @CRLF & _
" var length = arguments.length; // 1398" & @CRLF & _
" var date; // 1399" & @CRLF & _
" if (this instanceof NativeDate) { // 1400" & @CRLF & _
" var seconds = s; // 1401" & @CRLF & _
" var millis = ms; // 1402" & @CRLF & _
" if (hasSafariSignedIntBug && length >= 7 && ms > maxSafeUnsigned32Bit) { // 1403" & @CRLF & _
" // work around a Safari 8/9 bug where it treats the seconds as signed // 1404" & @CRLF & _
" var msToShift = Math.floor(ms / maxSafeUnsigned32Bit) * maxSafeUnsigned32Bit; // 1405" & @CRLF & _
" var sToShift = Math.floor(msToShift / 1e3); // 1406" & @CRLF & _
" seconds += sToShift; // 1407" & @CRLF & _
" millis -= sToShift * 1e3; // 1408" & @CRLF & _
" } // 1409" & @CRLF & _
" date = length === 1 && $String(Y) === Y ? // isString(Y) // 1410" & @CRLF & _
" // We explicitly pass it through parse: // 1411" & @CRLF & _
" new NativeDate(DateShim.parse(Y)) : // 1412" & @CRLF & _
" // We have to manually make calls depending on argument // 1413" & @CRLF & _
" // length here // 1414" & @CRLF & _
" length >= 7 ? new NativeDate(Y, M, D, h, m, seconds, millis) : // 1415" & @CRLF & _
" length >= 6 ? new NativeDate(Y, M, D, h, m, seconds) : // 1416" & @CRLF & _
" length >= 5 ? new NativeDate(Y, M, D, h, m) : // 1417" & @CRLF & _
" length >= 4 ? new NativeDate(Y, M, D, h) : // 1418" & @CRLF & _
" length >= 3 ? new NativeDate(Y, M, D) : // 1419" & @CRLF & _
" length >= 2 ? new NativeDate(Y, M) : // 1420" & @CRLF & _
" length >= 1 ? new NativeDate(Y instanceof NativeDate ? +Y : Y) : // 1421" & @CRLF & _
" new NativeDate(); // 1422" & @CRLF & _
" } else { // 1423" & @CRLF & _
" date = NativeDate.apply(this, arguments); // 1424" & @CRLF & _
" } // 1425" & @CRLF & _
" if (!isPrimitive(date)) { // 1426" & @CRLF & _
" // Prevent mixups with unfixed Date object // 1427" & @CRLF & _
" defineProperties(date, { constructor: DateShim }, true); // 1428" & @CRLF & _
" } // 1429" & @CRLF & _
" return date; // 1430" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")