re = /(?<=^|\s)\d+(?=[\s.,:;!?]|$)/
str = 'My number is +12 345 678. I have galaxy s3, its symbol 34abc.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end