$re = '/^\w+(?:\.jpg|\.png)?$/m';
$str = 'My awesome image.png
My_better_image.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);