re = /(^|((^|\s)(?!(void|int|double|char))[^\s]+)\s+)([a-zA-Z_]+\(\)?)/m
str = 'int f();
myStruct f();
f();
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end