$re = '/^((0)(2|4|3|7|8))[0-9]{2}[0-9]{2}[0-9]{1}[0-9]{3}$/m';
$str = '0290876787
0990876787
+6190876787
0732090000
0732090000
0432090000
0832090000';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;