$re = '/[a-zA-Z]{2,}(\d+)?/';
$str = 'Oceans11';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);