$re = '/^(?:(?:0*1(?:11)*(?:0+|$))+|0+)$/m';
$str = '1001110111
10110111
1
11
111
1111
11111
01
0000
10101010
1110001010000
00000001
011101001110111110001111111
0111010011101111100011111111
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);