$re = '/(?=(1.*?1hj))/';
$str = '1abcd1efg1hjk1lmn1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);