using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"h([^e])h\1";
string input = @"hoho
hihi
haha
hede
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}