$re = '/(?<=[abxy])-/m';
$str = 'a-x-b-x-a-y-b-y-b-x-a-x-a-y-a-x-b';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;