using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|""([^\\""]*(?:\\.[^""\\]*)*)""|([^\s""]+))";
string input = @"""foo bar""ANDbar""foo""AND""foofoo"" lorem ""impsum""";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}