const regex = /\b0+(?=[0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0+(?=[0-9])', 'gm')
const str = `00000.jpg
00001.jpg
00010.jpg
00011.jpg
00100.jpg
00101.jpg
00219.jpg
01000.jpg
12345.jpg
img.00002.jpg`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);