using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.{3}).*(\..{3,4})";
string substitution = @"$1...$2";
string input = @"sssssssssssssssssssssssssssssssssssssssssssss.txt";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}