package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\+0?1\s)?\(?\d{3}\)?[\s.-]\d{3}[\s.-]\d{4}$`)
var str = `444-666-1232`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}