use strict;
my $str = 'in .txt';
my $regex = qr/\s+(\.[^.]+)$/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";