const regex = /^(?![\W_])((?:([\w+-]{2,})\.?){1,})(?<![\W_])@(?![\W_])(?=[\w.-]{5,})(?=.+\..+)(?1)(?<![\W_])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![\\W_])((?:([\\w+-]{2,})\\.?){1,})(?<![\\W_])@(?![\\W_])(?=[\\w.-]{5,})(?=.+\\..+)(?1)(?<![\\W_])', 'gm')
const str = `# Valid
test@gm.com
test@gmail.com
aa-test@gmail.com
aa_test@gmail.com
aa.test@gmail.com
aa1test@gmail.com
aa1.test@gmail.com
aa1-test@gmail.com
1test@gmail.com
test@gmail.co.in
aa-test@gmail.co.in
aa_test@gmail.co.in
aa.test@gmail.co.in
aa1test@gmail.co.in
aa1.test@gmail.co.in
aa1-test@gmail.co.in
1test@gmail.co.in
addres+3@gmail.com
address1@gmail.com;adresse2@gmail.com;
address1@gmail.com;adresse2@gmail.com;address1@gmail.com;adresse2@gmail.com;
address1@gmail.com;
address1@gmail;adress2@gmail.com;addres+3@gmail.com;
# Invalid
test@gmail
.test@gmail.com
-test@gmail.com
_test@gmail.com
tes.t@gmail.com
t.e.st@gmail.com
t.-.est@gmail.com
.test.@gmail.com
test.@gmail.com
test.@.gmail.com
test@.gmail.com
test@.gmail.com.
test@gmail.com.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}