#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\d*\.)?\d+$"
Local $sString = "" & @CRLF & _
"22/09/2015 11:05:41 | Dispense complete for COTTON, final dispense weight was 0.0262" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:08:02 | Dispense complete for COTTON, final dispense weight was 0.0264" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:10:08 | Dispense complete for COTTON, final dispense weight was 0.0229" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:12:03 | Dispense complete for COTTON, final dispense weight was 0.0188" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:14:22 | Dispense complete for COTTON, final dispense weight was 0.0292" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:16:48 | Dispense complete for COTTON, final dispense weight was 0.0245" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:18:37 | Dispense complete for COTTON, final dispense weight was 0.0243" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:20:56 | Dispense complete for COTTON, final dispense weight was 0.0261" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:22:53 | Dispense complete for COTTON, final dispense weight was 0.0228" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:24:43 | Dispense complete for COTTON, final dispense weight was 0.0204" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:26:38 | Dispense complete for COTTON, final dispense weight was 0.0223" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:28:29 | Dispense complete for COTTON, final dispense weight was 0.0257" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:30:20 | Dispense complete for COTTON, final dispense weight was 0.0371" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:32:14 | Dispense complete for COTTON, final dispense weight was 0.0376" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:36:18 | Dispense complete for COTTON, final dispense weight was 0.0222" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:39:28 | Dispense complete for COTTON, final dispense weight was 0.0234" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:41:23 | Dispense complete for COTTON, final dispense weight was 0.0255" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:43:24 | Dispense complete for COTTON, final dispense weight was 0.0242" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:46:30 | Dispense complete for COTTON, final dispense weight was 0.0354" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"22/09/2015 11:50:04 | Dispense complete for COTTON, final dispense weight was 0.0294"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")