package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\d+)(dhms)`)
var str = `12d13h14m15s16D17H18M19s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}