re = /\s+inet ([0-9.].+)\/([0-9]+) (scope|brd)/m
str = '23: eth0@if24: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
link/ether 02:42:ac:11:00:02 brd ff:ff:ff:ff:ff:ff link-netnsid 0
inet 172.17.0.2/16 brd 172.17.255.255 scope global eth0
valid_lft forever preferred_lft forever'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end