$re = '/^.*\bSomething111\b[^.]*\./m';
$str = 'Something Something Something Something111
Something Something Something Something
Something Something Something Something222.
Something Something Something Something
Something Something Something Something333.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);