package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(\w*):(\S*)`)
var str = `key:value number:2 stuff:color(color)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}