package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[teststring]+$`)
var str = `Here is my [testring]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}