package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([-\d.]+[\/\+\-\*\^\%\!\&\|]{1,2}[-\d.]+)+$`)
var str = `ne*t
1*1
1*.5
1.5*2.5
-1.5*-2.5
1.5*2.5*3.5*4
2^2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}