import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=vertex)(?:\\s?-?\\d*\\.?\\d+)+";
final String string = "vertex\n"
+ "144.64329 -65.95227 -40.5391\n"
+ "244.25595 -77.64196 -51.07746\n"
+ "144.64738 23.13064 -40.53168\n"
+ "244.26259 67.13464 -51.0654\n"
+ "144.64968 -65.94874 36.17572\n"
+ "244.26407 -77.63749 46.41944\n\n"
+ "3434\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}