re = /^(?&nest)(?(DEFINE)(?'nest'\{(?>[^{}]|(?&nest))*\}))/
str = '{dfsdf{sdfdf{ {dfsdf} }}dfsf}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end