$re = '/(?:\b(?P<id_1>a|b|c)\b(?:.*?)(?P<id_2>q|w)?\b)/i';
$str = 'a something* q b c w';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);