$re = '/^(?:0|[1-9]\d*)(\.\d{1,4})?$/';
$str = '0.12345';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);