re = /(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[$@$!%*?&]).{8,}/m
str = '1oB!gb0s5
Pass@123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end