$re = '/(?i)[A-J],?\s?\d{1,2}\'/';
$str = 'Place this at A10';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);